GE Healthcare

GE Healthcare

Menu
Close

Sorry, your search for: did not find any results

Search Suggestions: Make sure your keyword(s) are spelled correctly Try another keyword(s) Try more general keyword(s)

Hemodynamic Recording, Electrophysiology Recording, and Cardiovascular Information Technologies

January 05, 2018
Meltdown / Spectre Vulnerability

GE Healthcare is aware of newly discovered hardware vulnerabilities, known as “Meltdown” and “Spectre”, within computing system processors that can potentially be exploited for malicious purposes and allow unauthorized access to data within the system. These vulnerabilities were initially attributed to Intel microprocessors but they affect a wider range of processors used in systems with various widely used operating systems. According to Intel, the exploits associated with this flaw do not have the potential to corrupt, modify, or delete data.

Hardware technology companies, including Intel, AMD and ARM Holdings, and several operating system vendors are developing an industry wide approach to resolve this issue. Hardware and firmware updates will be released by these companies as they become available.

GE Healthcare is reviewing information on this issue as it becomes available from our suppliers and will evaluate the need for remediation in any GE Healthcare products. At this time, we are not aware of any GE Healthcare devices or software that have been impacted by malicious activity associated with these vulnerabilities. GE recommends that customers follow good security practices that protect against malware within their operating networks.

GE Healthcare will continue to monitor this issue and will publish more information, including details about product specific impact or patches, as it becomes available.  

Reference: GE Healthcare Security Update

Security Patches

Changes for 6.9.6 Release 3: Added unqualified vulnerabilities
Changes for 6.9.6 Release 2: Added unqualified vulnerabilities
Changes for 6.9.6 Release 1: Added unqualified vulnerabilities
Changes for 6.9.5 and 6.9: Added unqualified vulnerabilities

Changes for Pre-6.9: Qualified new security patches

Pre-6.9: Security patch updates (last updated 27 December 2017)

Anti-Virus Instructions

Changes for 6.9.6 Release 3: Qualified installation instructions and added additional translations
Changes for 6.9.6 Release 2: Added German and French translations
Changes for 6.9.6 Release 1: None

Changes for Pre-6.9, 6.9, 6.9.5: None

Pre-6.9, 6.9, 6.9.5: Anti-Virus Installation Instructions (last updated 6 July 2017)

Software Requirements